Some users may be unable to download files
Incident Report for MLXP
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 15:08 EST
Investigating
When trying to download, the "in progress" / "beachball" icon may appear but the file doesn't start to download.
Posted Jan 14, 2025 - 14:35 EST
This incident affected: stp.mailinglists.com.