API lookups may timeout

Incident Report for MLXP

Resolved

This incident has been resolved.
Posted May 14, 2025 - 12:03 EDT

Monitoring

A fix has been implemented, and we are monitoring the situation.
Posted May 14, 2025 - 10:58 EDT

Investigating

We are witnessing API timeouts across several endpoints. We are investigating.
Posted May 14, 2025 - 10:33 EDT
This incident affected: api.mlxp.com.